
Salesforce Advanced Admin Exam Study Guide: Topic 2 - Data Management (15%) 

Salesforce Basics: For Advanced Admin Newbies 

If you’re leveling up to Advanced Admin or just getting started here, don’t stress—here’s a 
colossal, welcoming intro to get you excited, comfy, and ready to dive in. 

• What is Salesforce Advanced Admin?  

o It’s the pro tier of Salesforce mastery—an online platform where you 
transform your org into a data powerhouse, tackling advanced security, 
automation, and data management, all in the cloud with no tech chaos 
needed. 

o Picture it as your business’s data maestro—like a brilliant librarian who 
organizes, cleans, and protects your info, taking your basic Admin skills to 
the next level. 

• Why It’s a Total Win:  

o It goes beyond simple data entry—like adding Contacts or Accounts—and 
dives into heavy-duty stuff: mass imports, deduplication, backups, and 
audits. It’s like upgrading from tidying a desk to managing a bustling data 
warehouse—your team gets clean, reliable info without the mess. 

o As an Advanced Admin, you’re the data wizard—ensuring quality, scalability, 
and integrity, like teaching a super-smart robot to handle your org’s data with 
precision and flair. 

• Key Words to Start With:  

o Org: Your company’s Salesforce realm—like your team’s high-tech library 
where data lives and advanced tricks happen. 

o Setup: The control hub (top-right gear icon) where you tweak the deep stuff—
like the master console of your Salesforce data vault, giving you ultimate 
power. 

o CRM: Customer Relationship Management—the core of Salesforce, now 
with advanced tools to keep data pristine and actionable. 

• What This Topic Is All About:  

o “Data Management” is your deep dive into handling Salesforce data—
importing/exporting, ensuring quality, deduplicating, auditing changes, and 



managing mass updates. It’s like being the chief curator of your org’s data 
museum, keeping it clean, accessible, and secure. 

 

Overview 

"Data Management" (15%) is a critical piece of the Advanced Admin exam—it’s about 
mastering advanced data tools and strategies, from importing thousands of records to 
cleaning duplicates, exporting backups, and tracking changes. You’ll go beyond basic 
uploads, tackling enterprise-scale data tasks and quality control. It’s 15% of the exam—a 
hefty chunk—because clean, reliable data drives every Salesforce process. 

Exam Weight 

• Percentage: 15% 

• Why It Matters: Bad data kills efficiency—duplicates confuse reps, missing records 
stall deals, and poor audits risk compliance. With 15%, it’s a big part of your test 
score and a must-know for keeping an enterprise org humming. 

Objectives (In Super-Simple Terms) 

• Learn how to import and export tons of data—like adding 10,000 Leads or backing 
up Accounts—without breaking anything. 

• Figure out how to keep data clean—like merging duplicates or fixing errors—so your 
team trusts it. 

• Get comfy with mass updates—like changing 500 Owners at once—to save time. 

• Understand auditing—like tracking who changed what—to stay secure and 
compliant. 

 

Structure of the Study Guide 

• Definitions: Big, clear explanations of key terms. 

• Categories: Topics split into digestible chunks. 

• Bullet Points: Massive, beginner-friendly summaries with heaps of detail. 

• Tables: Side-by-side comparisons to keep it simple. 

• Practical Scenarios: Tons of real-world examples you can picture doing. 



• Study Tips: Step-by-step ways to nail this. 

 

Definitions (Huge Summaries with Tons of Beginner Details) 

• Data Import Wizard:  

o What It Is: A tool to upload data—like Leads or Contacts—from a file into 
Salesforce. 

o Details: Think of it as your data conveyor belt—it’s a simple, guided way to 
bring in up to 50,000 records from a CSV (spreadsheet). You map fields (e.g., 
“Name” to “Name”) and let it run—perfect for smaller, standard imports. 

• Data Loader:  

o What It Is: A power tool to import, update, delete, or export data—like 
millions of records. 

o Details: This is your data bulldozer—a desktop app for big jobs (up to 5 
million records), handling any object (standard or custom). It’s more complex 
but gives you control—like upserting (update or insert) or exporting backups. 

• Duplicate Rule:  

o What It Is: A rule to catch duplicates—like “Same Email” on Contacts—
before they save. 

o Details: Imagine it as your data bouncer—it spots matches (e.g., 
“john@acme.com” already exists) and can block, alert, or allow them. 
Advanced Admins tweak it to keep the org clean—like stopping duplicate 
Leads from piling up. 

• Matching Rule:  

o What It Is: A logic check—like “Email + Name match”—to define what’s a 
duplicate. 

o Details: This is your duplicate detector—it powers Duplicate Rules by setting 
criteria (e.g., “First Name AND Email”). It’s like telling Salesforce, “These 
fields mean it’s the same person”—flexible for your org’s needs. 

• Mass Update:  

o What It Is: Changing lots of records at once—like reassigning 1,000 Cases. 
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o Details: Think of it as your data paintbrush—it lets you update fields (e.g., 
“Owner = Jane”) across many records via tools like Data Loader or Mass 
Quick Actions. It’s a time-saver for big fixes. 

• Audit Trail:  

o What It Is: A log of changes—like “Who edited this field?”—for security and 
compliance. 

o Details: This is your data diary—it tracks admin-level changes (e.g., “Jane 
modified OWD”) for 6 months (or 18 with archiving). Advanced Admins use it 
to debug or prove compliance—like showing regulators who touched what. 

 

Categories 

• Advanced Data Tools: The big areas you’ll master.  

o Data Import and Export 

o Data Quality and Deduplication 

o Mass Updates and Deletes 

o Auditing and Monitoring 

 

Detailed Breakdown (Bullet Points with Massive Beginner Summaries) 

1. Advanced Data Tools 

• Data Import and Export  

o Summary: Tools to bring data in—like 10,000 Leads—or pull it out—like 
exporting Accounts—for backups or analysis, scaled for enterprise needs. 

o Details:  

▪ This is your data highway—moving info in and out of Salesforce with 
precision. The Data Import Wizard is easy for small jobs; Data Loader 
handles the big leagues. Advanced Admins master both—like juggling 
imports for 50 sales reps or exporting for audits. 

▪ How You Set It Up:  

▪ Data Import Wizard: Setup > Data > Data Import Wizard:  



▪ What It Does: Imports up to 50,000 records—standard 
objects (e.g., Leads, Contacts) or some customs. 

▪ Details:  

▪ Pick Object: Like “Contacts.” 

▪ Upload CSV: File—like “contacts.csv” (Name, 
Email, Phone). 

▪ Map Fields: Match—like “CSV: Email” to 
“Salesforce: Email.” 

▪ Options: “Add new,” “Update existing” (needs 
ID), or “Upsert” (ID or External ID). 

▪ Run: Imports—check “Recent Imports” for 
errors. 

▪ Why It’s Cool: Simple—like “Load 500 Leads from a 
trade show.” Guided—no tech skills needed. 

▪ Example: Import “leads.csv”—“Name, Company, 
Email”—to Leads, map fields, add new—500 prospects 
ready. 

▪ Data Loader: Download from Setup > Data > Data Loader:  

▪ What It Does: Imports, updates, deletes, exports—up 
to 5 million records, any object. 

▪ Details:  

▪ Login: Use Salesforce creds. 

▪ Action: Pick—like “Insert,” “Update,” “Export.” 

▪ Object: Like “Accounts.” 

▪ CSV: Upload—like “accounts.csv.” 

▪ Map: Match fields—like “CSV: Name” to 
“Salesforce: Account Name.” 

▪ Run: Processes—check success/error logs (e.g., 
“1000 succeeded, 2 failed”). 



▪ Why It’s Cool: Powerhouse—like “Export 1M 
Opportunities for audit.” Upsert flexes—like “Update if 
exists, else add.” 

▪ Example: Export “Opportunities”—filter “Stage = 
Closed Won,” save as “closed_deals.csv”—backup 
done. 

▪ Why It’s Great: Wizard’s quick, Loader’s robust—like a scooter for 
small trips, a truck for big hauls. Advanced Admins pick the right 
tool—like Loader for mass custom object imports. 

▪ What’s Tricky: Wizard limits—50K max, no deletes. Loader needs IDs 
for updates—prep CSVs right. Test small—like 10 records—before 
millions. 

▪ Real-Life Example: Import 20K “Orders__c” records via Data 
Loader—CSV with “Order Number, Amount,” upsert by “Order ID”—
orders synced fast. 

• Data Quality and Deduplication  

o Summary: Tools to keep data clean—like spotting and merging duplicate 
Contacts—ensuring trust and efficiency. 

o Details:  

▪ This is your data janitor—catching and fixing messes like two “Jane 
Doe” Contacts. Duplicate Rules block or flag, Matching Rules define 
duplicates, and merging cleans them up. Advanced Admins enforce 
quality—like deduping 10,000 Leads post-import. 

▪ How You Set It Up:  

▪ Matching Rules: Setup > Data > Duplicate Management > 
Matching Rules:  

▪ What It Does: Defines “duplicate”—like “Email AND 
Name.” 

▪ Details: “New”:  

▪ Object: Like “Contacts.” 



▪ Criteria: Add—like “Email (Exact),” “First Name 
(Fuzzy).” 

▪ Activate: Save, turn on—powers deduping. 

▪ Why It’s Cool: Smart—like “jane@acme.com + Jane” 
matches “jane@acme.com + J. Doe.” 

▪ Example: “Lead Matching”—“Email (Exact), Company 
(Fuzzy)”—catches “Acme” vs. “Acme Inc.” 

▪ Duplicate Rules: Setup > Data > Duplicate Management > 
Duplicate Rules:  

▪ What It Does: Acts on matches—like “Block 
duplicates.” 

▪ Details: “New”:  

▪ Object: Like “Leads.” 

▪ Matching Rule: Pick—like “Lead Matching.” 

▪ Action: “Block,” “Alert,” or “Allow (Report).” 

▪ Conditions: Optional—like “Lead Source = Web.” 

▪ Activate: Save, turn on—runs on save. 

▪ Why It’s Cool: Proactive—like “Stop that second John 
Smith!” Customizable—like “Alert sales, block support.” 

▪ Example: “Contact Dupes”—“Block” on “Contact 
Matching,” alert user—keeps Contacts unique. 

▪ Merging: Object record > “Find Duplicates”:  

▪ Details: Select duplicates (e.g., two “Jane Does”), 
merge—keep best data (e.g., latest phone). 

▪ Why It’s Cool: Cleans—like “One Jane, not three.” 
Preserves history—related records stick. 

▪ Why It’s Great: Prevents chaos—like “No more 5 Janes calling Acme.” 
Advanced Admins scale it—like deduping across regions. 
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▪ What’s Tricky: Fuzzy matching misses—like “Jon” vs. “John.” Test 
rules—too tight blocks legit records. Merging’s final—backup first. 

▪ Real-Life Example: “Lead Dupes” rule—“Email Exact” blocks, merge 
two “john@acme.com” Leads—clean slate. 

• Mass Updates and Deletes  

o Summary: Tools to change or remove tons of records—like reassigning 5,000 
Owners or deleting old Leads—fast and safe. 

o Details:  

▪ This is your data power tool—like a bulk editor or shredder. Use Data 
Loader, Mass Quick Actions, or list views to update/delete en masse. 
Advanced Admins wield it for efficiency—like fixing a bad import in 
minutes. 

▪ How You Set It Up:  

▪ Data Loader:  

▪ Details: “Update” or “Delete”:  

▪ CSV: Like “cases.csv”—“Id, OwnerId” (new 
owner’s ID). 

▪ Map: “Id” to “Id,” “OwnerId” to “Owner.” 

▪ Run: Updates—logs show “5000 succeeded.” 

▪ Why It’s Cool: Big scale—like “Delete 1M old Cases.” 
Precise—ID-driven. 

▪ Example: Update 10K Accounts—“Id, OwnerId = Jane’s 
ID”—all reassigned. 

▪ Mass Quick Actions: Setup > Object Manager > [Object] > 
Buttons, Links, Actions:  

▪ Details: “New Action”:  

▪ Type: “Update a Record.” 

▪ Fields: Like “Owner”—predefine or user picks. 

▪ Add to Layout: List view—select records, run. 

mailto:john@acme.com


▪ Why It’s Cool: User-friendly—like “Reps reassign 50 
Cases.” Quick—no CSV. 

▪ Example: “Case Reassign”—select 100 Cases, set 
“Owner = Mike”—done. 

▪ List Views: Object tab > List View > Filter > Edit:  

▪ Details: Filter—like “Created Date < 2023”—select all, 
“Delete” or inline edit. 

▪ Why It’s Cool: Simple—like “Clear 200 old Leads.” 
Visual—see what’s changing. 

▪ Why It’s Great: Saves hours—like “Reassign 5K records in 5 minutes.” 
Advanced Admins fix big oops—like “Wrong import? Gone!” 

▪ What’s Tricky: No undo—backup first (export CSV). IDs critical—
wrong ones fail. Test small—like 10 records—before mass. 

▪ Real-Life Example: Data Loader—“Delete Leads.csv,” “Id” for Leads > 
2 years—old junk cleared. 

• Auditing and Monitoring  

o Summary: Tracking changes—like “Who updated this Account?”—for 
security, compliance, and debugging. 

o Details:  

▪ This is your data watchdog—like a security camera. The Setup Audit 
Trail logs admin changes (e.g., “Jane tweaked OWD”), Field History 
tracks record edits (e.g., “Amount changed”). Advanced Admins use it 
to audit—like proving compliance or fixing errors. 

▪ How You Set It Up:  

▪ Setup Audit Trail: Setup > Security > View Setup Audit Trail:  

▪ Details: Logs 6 months (18 with archive)—like “Jane 
modified Profile 03/10/2025.” 

▪ Why It’s Cool: Big picture—like “Who changed 
sharing?” Compliance gold—exportable. 



▪ Example: Check—“Mike added Sharing Rule 
03/05/2025”—audit trail confirms. 

▪ Field History Tracking: Setup > Object Manager > [Object] > 
Fields & Relationships:  

▪ Details: “Set History Tracking”:  

▪ Pick fields—like “Amount,” “Stage” (up to 20). 

▪ View: Related List on record—“Amount: $5K to 
$6K, Jane, 03/10/2025.” 

▪ Why It’s Cool: Granular—like “Who bumped this deal?” 
Reports work—pull history. 

▪ Example: “Opportunity”—track “Stage,” see 
“Prospecting to Closed, Mike, 03/09/2025.” 

▪ Why It’s Great: Accountability—like “Jane owns that edit.” Advanced 
Admins debug—like “Why’s this wrong? Oh, Mike.” 

▪ What’s Tricky: 6-month limit—archive early. Field history maxes at 
20—choose wisely. Reports need setup—add “History” object. 

▪ Real-Life Example: “Account”—track “Owner,” audit shows “Jane to 
Mike, 03/08/2025”—ownership shift traced. 

 

Tables 

Table 1: Data Import Wizard vs. Data Loader 

What’s Different Data Import Wizard Data Loader 

Limit 50,000 records 5 million records 

Objects Standard + some custom Any object 

Actions Insert, Update, Upsert Insert, Update, Delete, Export 

Ease Guided, browser-based Manual, desktop app 

Table 2: Duplicate vs. Matching Rules 



What’s Different Duplicate Rules Matching Rules 

Purpose Action (block/alert) Logic (what’s a dupe) 

Setup Uses Matching Rule Defines match criteria 

Example “Block same Email” “Email + Name match” 

Table 3: Auditing Tools 

What’s Different Setup Audit Trail Field History Tracking 

Scope Admin changes (e.g., OWD) Record edits (e.g., Amount) 

Limit 6 months (18 archived) 20 fields per object 

View Setup page Record related list 

 

Practical Scenarios 

1. Import Leads:  

o Need: Add 5,000 trade show Leads. 

o Solution: Data Import Wizard—upload “leads.csv,” map “Name, Email,” 
insert—Leads loaded. 

2. Export Backup:  

o Need: Save all Closed Opportunities. 

o Solution: Data Loader—Export “Opportunities,” filter “Stage = Closed Won,” 
save “closed_opps.csv”—backup secured. 

3. Deduplicate Contacts:  

o Need: Stop duplicate “Jane Does.” 

o Solution: Matching Rule “Email Exact,” Duplicate Rule “Block”—merge two 
“jane@acme.com” Contacts—clean list. 

4. Mass Reassign:  

o Need: Shift 1,000 Cases to new owner. 
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o Solution: Data Loader—CSV “cases.csv” with “Id, OwnerId = Mike,” update—
Cases reassigned. 

5. Audit Change:  

o Need: Who changed Account Owner? 

o Solution: Field History on “Account”—“Owner: Jane to Mike, 03/10/2025”—
culprit found. 

 

Study Tips 

• Hands-On: Free org (developer.salesforce.com)—import 100 Leads, dedupe 
Contacts, export Cases. 

• Start Simple: Trailhead’s “Data Management for Advanced Admins”—free, with 
videos and tasks. 

• Focus: Master Import/Export (Wizard vs. Loader), Deduping (Rules), Mass Updates 
(Loader), Auditing (Trail/History). 

• Practice: “Import 5K records?” or “Track field changes?”—exam drills. 

• Beginner Boost: Watch “Advanced Data Management” on YouTube; try one task 
daily—like import, then dedupe. 

• Time: Spend 15%—7.5 hours of 50—split: 2 on Import/Export, 2 on Deduping, 2 on 
Updates, 1.5 on Auditing. 

 


